[Webkit-unassigned] [Bug 218401] [GPU Process] Flush canvas displayList from doAfterUpdateRendering

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 3 09:52:52 PST 2020


https://bugs.webkit.org/show_bug.cgi?id=218401

Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #412996|review?                     |review-
              Flags|                            |

--- Comment #8 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 412996
  --> https://bugs.webkit.org/attachment.cgi?id=412996
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=412996&action=review

Almost there! Let's do one more round.

> Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:310
> +    bool needsPreparationForDisplay() const final { return true; }

This needs to also consult the buffer's shouldEagerlyFlush(), otherwise you've changed the behavior at Document::canvasChanged().

> Source/WebCore/platform/graphics/ImageBuffer.h:71
> +    virtual bool shouldEagerlyFlush() { return false; }

I'm trying to think of a better name for this. How about prefersPreparationForDisplay().

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20201103/672d38da/attachment.htm>


More information about the webkit-unassigned mailing list