[Webkit-unassigned] [Bug 211698] Use alias template to define `match_constness` in Wtf/wtp/TypeCasts.h

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun May 10 14:49:08 PDT 2020


https://bugs.webkit.org/show_bug.cgi?id=211698

Yusuke Suzuki <ysuzuki at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #398977|review?                     |review+, commit-queue-
              Flags|                            |

--- Comment #2 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 398977
  --> https://bugs.webkit.org/attachment.cgi?id=398977
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=398977&action=review

r=me with nit.

> Source/WTF/wtf/TypeCasts.h:71
> +using match_constness =
> +    typename std::conditional<std::is_const<Reference>::value, typename std::add_const<T>::type, typename std::remove_const<T>::type>::type;

`match_correctness` looks like not following to the WebKit's naming convention. Based on https://bugs.webkit.org/show_bug.cgi?id=140905#c4, I guess that this is intentionally using C++ STL's naming convention here.
Then, can you change this to `match_constness_t`? When using alias template and generating type without using `::type`, C++ STL uses `_t` suffix. e.g. https://en.cppreference.com/w/cpp/types/make_signed

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200510/15ed94c1/attachment.htm>


More information about the webkit-unassigned mailing list