[Webkit-unassigned] [Bug 209017] pep8.py:110: FutureWarning: Possible nested set at position 1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 13 07:37:16 PDT 2020


https://bugs.webkit.org/show_bug.cgi?id=209017

--- Comment #2 from Jonathan Bedard <jbedard at apple.com> ---
(In reply to Michael Catanzaro from comment #0)
> This warning occurs when running webkit-patch with python 3.7.6:
> 
> $ webkit-patch upload --request-commit
> /home/mcatanzaro/Projects/WebKit/Tools/Scripts/webkitpy/thirdparty/
> autoinstalled/pep8.py:110: FutureWarning: Possible nested set at position 1
>   EXTRANEOUS_WHITESPACE_REGEX = re.compile(r'[[({] | []}),;:]')
> 
> I think we need to update our autoinstalled modules to replace pep8 with its
> replacement, pycodestyle.

Does pycodestyle work with Python 2.7?

Our automation is still primarily Python 2.7. Although all scripts should be Python 3 compliant now, we still aren't running things that way in most places.

I think our oldest supported OS is now Mojave, so we probably aren't far from a post-Python 2 world in WebKit, but I haven't had any conversations about that it the last few weeks.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200313/78d1c660/attachment.htm>


More information about the webkit-unassigned mailing list