[Webkit-unassigned] [Bug 213086] New: DragState::type should be Optional<DragSourceAction> instead of OptionSet<DragSourceAction>
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Jun 11 11:20:50 PDT 2020
https://bugs.webkit.org/show_bug.cgi?id=213086
Bug ID: 213086
Summary: DragState::type should be Optional<DragSourceAction>
instead of OptionSet<DragSourceAction>
Product: WebKit
Version: Other
Hardware: Unspecified
OS: Unspecified
Status: NEW
Severity: Normal
Priority: P2
Component: DOM
Assignee: webkit-unassigned at lists.webkit.org
Reporter: ddkilzer at webkit.org
CC: darin at apple.com, thorton at apple.com,
wenson_hsieh at apple.com
Depends on: 212885
Per Darin's feedback in Bug 212885 Comment #12, DragState::type should be Optional<DragSourceAction> instead of OptionSet<DragSourceAction>.
'''
Refactoring this to be explicitly "OptionSet" when before it was not explicit is making the confusion worse, so I think we need to straighten this out first.
I guess there is some code can set the type to more than one thing. But this seems disorganized and messy. I think it’s not really a general set. It’s just one type plus possibly "selection". Seems really messy. I suppose you aren’t making it worse, but all this "hasExactlyOneBitSet" stuff is just what happens when we make the data structure too confusing. Clearly the "selection" is an independent flag, and need not be included in an option set.
'''
Referenced Bugs:
https://bugs.webkit.org/show_bug.cgi?id=212885
[Bug 212885] [IPC] Adopt enum class for DragSourceAction
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200611/513d1a42/attachment-0001.htm>
More information about the webkit-unassigned
mailing list