[Webkit-unassigned] [Bug 198830] [GTK] Several media related tests crash sometimes with the same error

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 28 12:28:59 PST 2020


Lauro Moura <lmoura at igalia.com> changed:

           What    |Removed                     |Added
                 CC|                            |lmoura at igalia.com

--- Comment #9 from Lauro Moura <lmoura at igalia.com> ---
About one week before this bug was reported, the xcb package was upgraded in the test bot:

> slave at bb-webkit-release-test-64 /var/log $ zgrep xcb1-dev dpkg.log.3.gz 
> 2019-06-04 01:08:53 upgrade libxcb1-dev:amd64 1.12-1 1.13.1-2

There is also this bug reported in upstream xcb about Skype (Chromium-based) freezing when playing video :

* [Regression 1.12->1.13] "read from connection when polling" causes video to freeze

I tried reverting the referenced commit to see if it changed something but the last set of tests reported by Diego kept crashing.

There is also some other bugs that may be related:

* Gstreamer: [glimagesink: Xlib / xcb assertion with client-draw signal]
  * Closed and opened the mesa bug below as it was assumed it is a driver issue

* Mesa: [crash OpenGL rendering to multiple X11 Window in multiple threads]
  * No new action other than the initial report

* Ubuntu GTK2 app: [!xcb_xlib_threads_sequence_lost error with GTK2 applications]

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200128/211ff888/attachment.htm>

More information about the webkit-unassigned mailing list