[Webkit-unassigned] [Bug 205861] [GTK][Flatpak SDK] Crashes in GTK drag and drop

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 9 07:11:21 PST 2020


https://bugs.webkit.org/show_bug.cgi?id=205861

Carlos Garcia Campos <cgarcia at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |INVALID

--- Comment #4 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to Philippe Normand from comment #0)
[...]
> 
> Looking at the cursors in libgtk:
> sh-5.0$ gresource list /usr/lib/x86_64-linux-gnu/libgtk-3.so|grep cursor
> /org/gtk/libgtk/cursor/dnd-ask.png
> /org/gtk/libgtk/cursor/dnd-copy.png
> /org/gtk/libgtk/cursor/dnd-link.png
> /org/gtk/libgtk/cursor/dnd-move.png
> /org/gtk/libgtk/cursor/dnd-none.png
> 
> Doesn't seem to match with what's in the code:
> https://gitlab.gnome.org/GNOME/gtk/blob/3.24.10/gtk/gtkdnd.c#L281
>   { GDK_ACTION_ASK,   "dnd-ask",  NULL, NULL },
>   { GDK_ACTION_COPY,  "copy", NULL, NULL },
>   { GDK_ACTION_MOVE,  "move", NULL, NULL },
>   { GDK_ACTION_LINK,  "alias", NULL, NULL },
>   { 0              ,  "no-drop", NULL, NULL },

Ah, good catch! This is probably the reason why ensure_drag_cursor_pixbuf() si failing then. I guess nobody noticed before because gdk_cursor_new_from_name() always works with "copy". So, I think there are actually two separate issues:

1.- gdk_cursor_new_from_name() is failing
2.- The cursor names don't match the resources names.

It should be easy to fix 2. we could do:

char *path = g_strconcat ("/org/gtk/libgtk/cursor/dnd-",  drag_cursors[i].name, ".png", NULL);

and rename dnd-ask to ask. In any case, not a WebKit bug for sure.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200109/9554e480/attachment.htm>


More information about the webkit-unassigned mailing list