[Webkit-unassigned] [Bug 207491] Add canShare function for Web Share API v2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 24 14:13:14 PST 2020


https://bugs.webkit.org/show_bug.cgi?id=207491

--- Comment #13 from Tim Horton <thorton at apple.com> ---
Comment on attachment 391562
  --> https://bugs.webkit.org/attachment.cgi?id=391562
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=391562&action=review

Almost done!

> Source/WebCore/page/RuntimeEnabledFeatures.h:610
> +    bool m_WebShareFileAPIEnabled { false };

lower-case the leading W

> Source/WebKit/Shared/WebPreferences.yaml:1959
> +WebShareFileAPIEnabled:
> +    type: bool
> +    defaultValue: false
> +    humanReadableName: "Web Share File API"
> +    humanReadableDescription: "Enable sharing of files through Web Share API"
> +    webcoreBinding: RuntimeEnabledFeatures
> +    category: experimental

I think it should be called Web Share API Level 2, since it will cover both canShare and `file`

> Source/WebKitLegacy/mac/WebView/WebPreferencesPrivate.h:653
> +- (void)setWebShareFileAPIEnabled:(BOOL)flag;

No need for Legacy WebKit SPI, we'll never enable it in Legacy WebKit (we don't even have Level 1 support there).

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200224/2024fe51/attachment.htm>


More information about the webkit-unassigned mailing list