[Webkit-unassigned] [Bug 191532] ASSERTION FAILED: !m_embeddedObjectsToUpdate->contains(nullptr) in WebCore::FrameView::updateEmbeddedObjects

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 17 12:31:18 PST 2020


https://bugs.webkit.org/show_bug.cgi?id=191532

Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #390903|review?, commit-queue?      |review+, commit-queue-
              Flags|                            |

--- Comment #16 from Darin Adler <darin at apple.com> ---
Comment on attachment 390903
  --> https://bugs.webkit.org/attachment.cgi?id=390903
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=390903&action=review

Looks good

> Source/WebCore/html/HTMLAppletElement.cpp:99
> +    return canEmbedJava()? HTMLPlugInElement::renderWidgetLoadingPlugin() : nullptr;

WebKit coding style: Need a space before the "?" here.

When calling through to "super", I think it’s usually better style to write the actual base class, HTMLPlugInImageElement, rather than the class that has the function in it skipping a level of inheritance HTMLPlugInElement.

> Source/WebCore/html/HTMLEmbedElement.cpp:85
> +    RenderWidget* widget = HTMLPlugInElement::renderWidgetLoadingPlugin();
> +    
> +    return widget? widget : findWidgetRenderer(this);

Ditto, same two comments here.

> Source/WebCore/html/HTMLPlugInElement.cpp:169
> +    return renderWidget(); // This will return 0 if the renderer is not a RenderWidget.

I think we should say nullptr rather than "0" in this comment. I know we are just moving it.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200217/e886b20f/attachment.htm>


More information about the webkit-unassigned mailing list