[Webkit-unassigned] [Bug 207621] New: [JSC] Operand should be small

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 12 03:40:00 PST 2020


            Bug ID: 207621
           Summary: [JSC] Operand should be small
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: ysuzuki at apple.com

We added OperandKind to Operand, but it doubles the sizeof(Operand).
And it is critical since it is included in DFG's VariableEvent in VariableEventStream.
We should make it 4 bytes.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200212/cdfa9827/attachment.htm>

More information about the webkit-unassigned mailing list