[Webkit-unassigned] [Bug 219672] [GPU Process] Cache Font objects

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 9 09:22:33 PST 2020


https://bugs.webkit.org/show_bug.cgi?id=219672

--- Comment #2 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 415728
  --> https://bugs.webkit.org/attachment.cgi?id=415728
WIP

View in context: https://bugs.webkit.org/attachment.cgi?id=415728&action=review

> Source/WebCore/platform/graphics/displaylists/DisplayListItems.h:934
> +class CacheFont {

CacheFont is an odd name. CachedFont?

> Source/WebCore/platform/graphics/displaylists/DisplayListItems.h:955
> +    uint32_t itemID() const { return m_itemID; }

This doesn't seem to be used?

> Source/WebCore/platform/graphics/displaylists/DisplayListItems.h:966
> +    static WEBCORE_EXPORT uint32_t s_currentItemID;

Why WEBCORE_EXPORT? Can we give this a typedef?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20201209/ae0b1119/attachment.htm>


More information about the webkit-unassigned mailing list