[Webkit-unassigned] [Bug 198604] Refactoring of architectural Register Information

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 11 10:24:42 PDT 2019


Caio Lima <ticaiolima at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |ticaiolima at gmail.com

--- Comment #18 from Caio Lima <ticaiolima at gmail.com> ---
Comment on attachment 371733
  --> https://bugs.webkit.org/attachment.cgi?id=371733
Revised Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=371733&action=review

I didn't read everything, but I've left some comments.

> Source/JavaScriptCore/assembler/ARM64Assembler.h:169
> +//   in ARM64Registers.h on the macro definition of REGNS 

nit: There is some extra space here.

> Source/JavaScriptCore/assembler/ARM64Assembler.h:173
> +#define REGISTER_ID(id, nsid, name, r, cs) id,

nit: Since we are not using `r` and `cs`, I think we could remove them.

> Source/JavaScriptCore/assembler/ARM64Assembler.h:185
> +#define REGISTER_ID(id, nsid, name) id,


> Source/JavaScriptCore/assembler/ARM64Assembler.h:194
> +#define REGISTER_ID(id, nsid, name, r, cs) id,


> Source/JavaScriptCore/assembler/ARM64Assembler.h:229
> +#define REGISTER_NAME(id, nsid, name, r, cs) name,


> Source/JavaScriptCore/assembler/ARM64Assembler.h:251
> +#define REGISTER_NAME(id, nsid, name, r, cs) name,


> Source/JavaScriptCore/assembler/ARM64Registers.h:29
> +#define REGNS ARM64Registers

One suggestion is to use `REGISTER_NAMESPACE` instead of `REGNS`.

> Source/JavaScriptCore/assembler/ARM64Registers.h:36
> +#define macro(m, ...) m(__VA_ARGS__)

Over JSC codebase we usually have `FOR_EACH...(macro)` style. Using `macro` seems a little bit confusing to me. Can we rename it to `macro_forward` or something else?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190611/260d6c5e/attachment.html>

More information about the webkit-unassigned mailing list