[Webkit-unassigned] [Bug 199896] Expose additional resource load statistics to clients

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 22 09:44:57 PDT 2019


https://bugs.webkit.org/show_bug.cgi?id=199896

--- Comment #5 from Saagar Jha <saagarjha at apple.com> ---
(In reply to Chris Dumez from comment #3)

I've uploaded a new patch that takes your feedback into account. Specifically:

> Comment on attachment 374365 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=374365&action=review
> 
> > Source/WebKit/NetworkProcess/NetworkSession.cpp:154
> > +void NetworkSession::didLoadResourceWithoutCookies(const String& resource, WebCore::PageIdentifier pageID)
> 
> This should not be a String, likely a URL.

Yes, this has been changed.

> > Source/WebKit/NetworkProcess/NetworkSession.h:90
> > +    void didLoadResourceWithoutCookies(const String &resource, WebCore::PageIdentifier);
> 
> & on wrong side.

Fixed.

> > Source/WebKit/NetworkProcess/cocoa/NetworkDataTaskCocoa.mm:210
> > +        session.didLoadResourceWithoutCookies(request.url().string(), pageID);
> 
> I would call this willLoad... rather than didLoad.. given that we have not
> started loading yet.

Good point, renamed.

> > Source/WebKit/UIProcess/API/APINavigationClient.h:156
> > +    virtual void didLoadResourceWithoutCookies(const WTF::String& resource) { }
> 
> URL, also WTF:: is not needed.

I seemed to need it: since this is in the API namespace, URL resolves to API::URL instead of WTF::URL (I think that's why the other instances also qualify using the namespace?)

> > Source/WebKit/UIProcess/Cocoa/NavigationState.h:146
> > +        void didLoadResourceWithoutCookies(const WTF::String& resource) override;
> 
> URL, also WTF:: is not needed.

Done.

> > Source/WebKit/UIProcess/Cocoa/NavigationState.mm:1165
> > +void NavigationState::NavigationClient::didLoadResourceWithoutCookies(const WTF::String& resource)
> 
> URL, also WTF:: is not needed.

Done.

> > Source/WebKit/UIProcess/Network/NetworkProcessProxy.cpp:931
> > +void NetworkProcessProxy::didLoadResourceWithoutCookies(const String &resource, PageIdentifier pageID)
> 
> & on wrong side, and should be a URL.

Done.

> > Source/WebKit/UIProcess/Network/NetworkProcessProxy.cpp:933
> > +    if (auto page = WebProcessProxy::webPage(pageID))
> 
> auto*

Does it actually matter, or is this just part of WebKit's style?

> > Source/WebKit/UIProcess/Network/NetworkProcessProxy.messages.in:52
> > +    DidLoadResourceWithoutCookies(String resource, WebCore::PageIdentifier pageID);
> 
> URL

Done.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190722/3865048b/attachment.html>


More information about the webkit-unassigned mailing list