[Webkit-unassigned] [Bug 199896] Expose additional resource load statistics to clients

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 19 11:14:14 PDT 2019


https://bugs.webkit.org/show_bug.cgi?id=199896

Chris Dumez <cdumez at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |cdumez at apple.com

--- Comment #3 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 374365
  --> https://bugs.webkit.org/attachment.cgi?id=374365
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=374365&action=review

> Source/WebKit/NetworkProcess/NetworkSession.cpp:154
> +void NetworkSession::didLoadResourceWithoutCookies(const String& resource, WebCore::PageIdentifier pageID)

This should not be a String, likely a URL.

> Source/WebKit/NetworkProcess/NetworkSession.h:90
> +    void didLoadResourceWithoutCookies(const String &resource, WebCore::PageIdentifier);

& on wrong side.

> Source/WebKit/NetworkProcess/cocoa/NetworkDataTaskCocoa.mm:210
> +        session.didLoadResourceWithoutCookies(request.url().string(), pageID);

I would call this willLoad... rather than didLoad.. given that we have not started loading yet.

> Source/WebKit/UIProcess/API/APINavigationClient.h:156
> +    virtual void didLoadResourceWithoutCookies(const WTF::String& resource) { }

URL, also WTF:: is not needed.

> Source/WebKit/UIProcess/Cocoa/NavigationState.h:146
> +        void didLoadResourceWithoutCookies(const WTF::String& resource) override;

URL, also WTF:: is not needed.

> Source/WebKit/UIProcess/Cocoa/NavigationState.mm:1165
> +void NavigationState::NavigationClient::didLoadResourceWithoutCookies(const WTF::String& resource)

URL, also WTF:: is not needed.

> Source/WebKit/UIProcess/Network/NetworkProcessProxy.cpp:931
> +void NetworkProcessProxy::didLoadResourceWithoutCookies(const String &resource, PageIdentifier pageID)

& on wrong side, and should be a URL.

> Source/WebKit/UIProcess/Network/NetworkProcessProxy.cpp:933
> +    if (auto page = WebProcessProxy::webPage(pageID))

auto*

> Source/WebKit/UIProcess/Network/NetworkProcessProxy.messages.in:52
> +    DidLoadResourceWithoutCookies(String resource, WebCore::PageIdentifier pageID);

URL

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190719/56f6095b/attachment.html>


More information about the webkit-unassigned mailing list