[Webkit-unassigned] [Bug 193246] ASSERT when paused in debugger and console evaluation causes exception

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 8 14:05:43 PST 2019


https://bugs.webkit.org/show_bug.cgi?id=193246

Mark Lam <mark.lam at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #358634|review?                     |review+
              Flags|                            |

--- Comment #4 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 358634
  --> https://bugs.webkit.org/attachment.cgi?id=358634
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=358634&action=review

r=me with some suggestions.

> Source/JavaScriptCore/debugger/DebuggerEvalEnabler.h:37
> +        EvalOnCurrentFrame,
> +        EvalOnDebuggerCallFrame,

Now that I have more time to think about it, how about naming these as:
    EvalOnCurrentFrame => EvalOnCurrentCallFrame
    EvalOnDebuggerCallFrame => EvalOnCallFrameAtDebuggerEntry

I think these names would be clearer.  What do you think?

> Source/JavaScriptCore/runtime/JSGlobalObject.h:494
> +    const ExecState* m_evalDebuggerCallFrame { nullptr };

I suggest naming this as "m_callFrameAtDebuggerEntry" instead.

> Source/JavaScriptCore/runtime/JSGlobalObject.h:904
> +    const ExecState* evalDebuggerCallFrame() const { return m_evalDebuggerCallFrame; }
> +    void setEvalDebuggerCallFrame(const ExecState* callFrame) { m_evalDebuggerCallFrame = callFrame; }

I suggest renaming these as callFrameAtDebuggerEntry() and setCallFrameAtDebuggerEntry() instead.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190108/a81baa8b/attachment.html>


More information about the webkit-unassigned mailing list