[Webkit-unassigned] [Bug 195167] [CoordinatedGraphics] Unify DrawingArea classes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 28 11:40:25 PST 2019


https://bugs.webkit.org/show_bug.cgi?id=195167

--- Comment #6 from Don Olmstead <don.olmstead at sony.com> ---
Comment on attachment 363243
  --> https://bugs.webkit.org/attachment.cgi?id=363243
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=363243&action=review

This is building locally. I'll see what the bots have to say about it.


One nit on this patch is that there's ports not turning on CoordinatedGraphics are taking in code that's marked as CoordinatedGraphics. Its a bit weird seeing USE(COORDINATED_GRAPHICS) inside there. Maybe a better name is required.

Also as a followup it might be nice to have a platform specific cmake or SourcesCoordinatedGraphics.txt to keep the ports in sync with builds.

> Source/WebKit/PlatformWin.cmake:-83
> -    WebProcess/WebPage/DrawingAreaImpl.cpp

This was still there in the original patch so CMake failed to create the project.

> Source/WebKit/WebProcess/WebPage/DrawingArea.h:147
> -#if USE(COORDINATED_GRAPHICS)
> -    virtual void didChangeViewportAttributes(WebCore::ViewportAttributes&&) = 0;
> -#endif
> -
>  #if USE(COORDINATED_GRAPHICS) || USE(TEXTURE_MAPPER)
> +    virtual void didChangeViewportAttributes(WebCore::ViewportAttributes&&) = 0;
>      virtual void deviceOrPageScaleFactorChanged() = 0;
>  #endif

I moved didChangeViewportAttributes because its in DrawingAreaCoordinatedGraphics and WinCairo errored since it was marked as override.

It looks like these two methods could probably just be moved completely to DrawingAreaCoordinatedGraphics but I did not do so since I'm just making this patch compile.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190228/36f34741/attachment.html>


More information about the webkit-unassigned mailing list