[Webkit-unassigned] [Bug 193665] [iOS] Tiles not created in large scrollable iframes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Feb 3 21:32:06 PST 2019


https://bugs.webkit.org/show_bug.cgi?id=193665

Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #361020|review?                     |review+
              Flags|                            |

--- Comment #22 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 361020
  --> https://bugs.webkit.org/attachment.cgi?id=361020
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=361020&action=review

r=me but at least rename the setScrollPositionToScrollingLayer/syncScrollPositionToScrollingLayer functions, and maybe move them.

> Source/WebCore/ChangeLog:4
> +        https://bugs.webkit.org/show_bug.cgi?id=193665

And rdar://problem/47743603.

> Source/WebCore/page/scrolling/AsyncScrollingCoordinator.cpp:473
> +void AsyncScrollingCoordinator::setScrollPositionToScrollingLayer(FrameView& frameView)

setScrollPositionForScrollingLayer? Setting the position "to" a layer doesn't make sense. Also we're trying to avoid the term "scrolling layer".

For overflow, I implemented this equivalent in RenderLayerBacking::setLocationOfScrolledContents(ScrollOffset scrollOffset, ScrollingLayerPositionAction setOrSync). Maybe this code should live in RenderLayerCompositor?

Another option is to give the ScrollingStateTreeNodes this responsibility.

> Source/WebCore/page/scrolling/AsyncScrollingCoordinator.cpp:485
> +void AsyncScrollingCoordinator::syncScrollPositionToScrollingLayer(FrameView& frameView)

Also needs better name/better home.

> Source/WebKit/UIProcess/RemoteLayerTree/ios/ScrollingTreeScrollingNodeDelegateIOS.mm:219
> +    if (scrollingStateNode.hasChangedProperty(ScrollingStateScrollingNode::ScrollContainerLayer))
> +        m_scrollLayer = scrollingStateNode.scrollContainerLayer();

Much less confusing.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190204/f83d38ff/attachment.html>


More information about the webkit-unassigned mailing list