[Webkit-unassigned] [Bug 189824] New: Rename Frame to BrowsingContext

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 21 03:16:23 PDT 2018


            Bug ID: 189824
           Summary: Rename Frame to BrowsingContext
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Frames
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: koivisto at iki.fi

"Frame" is a confusing name for a non-visual object. "Browsing context" is an HTML spec term that matches well what the Frame class actually represents. We literally have this code in Document:

    bool hasBrowsingContext() const { return !!frame(); }

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180921/f076063a/attachment.html>

More information about the webkit-unassigned mailing list