[Webkit-unassigned] [Bug 189277] New: [WebAuthN] Polish AuthenticatorManager and rename it to AuthenticatorCoordinator
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Sep 4 15:39:40 PDT 2018
https://bugs.webkit.org/show_bug.cgi?id=189277
Bug ID: 189277
Summary: [WebAuthN] Polish AuthenticatorManager and rename it
to AuthenticatorCoordinator
Product: WebKit
Version: WebKit Nightly Build
Hardware: Unspecified
OS: Unspecified
Status: NEW
Severity: Normal
Priority: P2
Component: WebCore Misc.
Assignee: webkit-unassigned at lists.webkit.org
Reporter: jiewen_tan at apple.com
This task aims to polish AuthenticatorManager such that:
1) it is no longer a singleton. Instead, it will live with Page. It was a singleton simply because static PublicKeyCredential::isUserVerifyingPlatformAuthenticatorAvailable() have to access it. However, the issue can be solved by adding an attribute [CallWith=Document]. Therefore, there is no such need. Also, the singleton is illy implemented as it also owns a single IPC proxy to UI Process which means different web pages will talk to the same web page proxy. Anyway, making it live with Page should solve the problem.
2) Since we are now planning to support external authenticators, the manager of all authenticators will then have to live in UI Process which makes this AuthenticatorManager obsolete. Instead, rename it to AuthenticatorCoordinator.
3) Rename CredentialsMessenger to AuthenticatorCoordinatorClient to tight it to WebAuthN. Also, simplify the message reply model as PublicKeyCredentialCreationOptions/PublicKeyCredentialRequestOptions => ExceptionData/PublicKeyCredential for makeCredential/getAssertion operations.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180904/7db29ec5/attachment.html>
More information about the webkit-unassigned
mailing list