[Webkit-unassigned] [Bug 192197] Rename ENABLE_SUBTLE_CRYPTO to ENABLE_WEB_CRYPTO

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 30 13:53:39 PST 2018


--- Comment #8 from Jiewen Tan <jiewen_tan at apple.com> ---
(In reply to Michael Catanzaro from comment #7)
> (In reply to Jiewen Tan from comment #6)
> > Maybe it would be better to rename ENABLE_WEB_CRYPTO to
> > ENABLE_SUBTLE_CRYPTO. From the Crypto class, I believe the crypto interface
> > is enabled by default for all ports? Just the SubtleCrypto interface is
> > platform dependent.
> ENABLE_WEB_CRYPTO exists only to rename the ENABLE_SUBTLE_CRYPTO option so
> that it can be presented as a public build option. You'll see nothing is
> guarded by it, it's just a stub option so that we don't have to expose a
> confusing internal name ENABLE_SUBTLE_CRYPTO.

The whole thing is a little bit subtle. I saw confusions on both sides. Since the guard is not needed for Apple ports, I will r+ this patch as you both thinks it is good.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20181130/946ab709/attachment.html>

More information about the webkit-unassigned mailing list