[Webkit-unassigned] [Bug 165072] [GTK] Difficult to read combo box text in dark theme

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 31 23:56:46 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=165072

Carlos Garcia Campos <cgarcia at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |cgarcia at igalia.com
 Attachment #341720|review?                     |review-
              Flags|                            |

--- Comment #13 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 341720
  --> https://bugs.webkit.org/attachment.cgi?id=341720
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=341720&action=review

> Source/WebCore/rendering/RenderTheme.cpp:219
> +#if PLATFORM(GTK)
> +    case ListboxPart:
> +        return adjustListboxStyle(styleResolver, style, element);
> +#endif

Do not use platform ifdefs here.

> Source/WebCore/rendering/RenderTheme.cpp:952
> +#if PLATFORM(GTK)
> +void RenderTheme::adjustListboxStyle(StyleResolver&, RenderStyle&, const Element*) const
> +{
> +}
> +#endif

We could have a default empty implementation in the header for ports not implementing this.

> Source/WebCore/rendering/RenderTheme.h:310
> +#if PLATFORM(GTK)
> +    virtual void adjustListboxStyle(StyleResolver&, RenderStyle&, const Element*) const;
> +#endif

Remove the platform ifdefs here and simply use an empty implementation here like other virtual methods do. I wouldn't make it const, even if it's true that the gtk implementation is const.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180601/01b99dda/attachment-0001.html>


More information about the webkit-unassigned mailing list