[Webkit-unassigned] [Bug 185804] New: BooleanLattice should be a class

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat May 19 12:57:32 PDT 2018


            Bug ID: 185804
           Summary: BooleanLattice should be a class
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: All
                OS: All
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Web Template Framework
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: fpizlo at apple.com

This would work a lot better as a class with methods. Then we could ensure that the default value is always Bottom, we could have nice conversions to and from boolean, and things like the leastUpperBound function could be a member function with a nicer name.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180519/954875e8/attachment-0001.html>

More information about the webkit-unassigned mailing list