[Webkit-unassigned] [Bug 126907] [GTK] Hardcoded text color in input fields

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 25 07:55:29 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=126907

--- Comment #78 from Michael Catanzaro <mcatanzaro at igalia.com> ---
(In reply to Carlos Garcia Campos from comment #57)
> > Source/WebCore/platform/gtk/RenderThemeGadget.cpp:92
> > +    static NeverDestroyed<GRefPtr<GtkStyleContext>> baseContext = createBaseStyleContext();
> 
> This is weird, we have a create function that is always going to be used
> with a NeverDestroyed. I would rename createBaseStyleContext() as
> baseStyleContext() and make it return a plain pointer GtkStyleContext*. Then
> make the path created inside the function static and return .get().

Please also still use NeverDestroyed, though. It should be NeverDestroyed<GtkStyleContext> with no GRefPtr involved. (It was dumb of me to suggest that.) See bug #186969 for a bunch of examples of how to do this. This will ensure we avoid leak warnings from asan.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180625/179eb0ed/attachment.html>


More information about the webkit-unassigned mailing list