[Webkit-unassigned] [Bug 186359] WIP Add script to update web-platform-tests expectations after import

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 7 10:07:05 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=186359

youenn fablet <youennf at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |youennf at gmail.com

--- Comment #6 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 342162
  --> https://bugs.webkit.org/attachment.cgi?id=342162
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=342162&action=review

> Tools/ChangeLog:8
> +        * Scripts/update-w3c-tests: Added.

Could be named update-w3c-test-expectations

> Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:429
> +        json_results_generator.write_json(self._filesystem, summarized_results, full_results_path_1)

This would overwrite "full-results.json" which might not be what we want.
Maybe for now, we should just load the current full-results.json file and remove ADD_Results prefix and suffix in the test_updater script with a FIXME comment.

> Tools/Scripts/webkitpy/w3c/test_updater.py:34
> + intended to be uses after runnning Tools/Scripts/import-w3c-tests to assist in

s/users/used

> Tools/Scripts/webkitpy/w3c/test_updater.py:105
> +class TestExpecationUpdater(object):

s/TestExpecationUpdater/TestExpectationUpdater/

> Tools/Scripts/webkitpy/w3c/test_updater.py:123
> +        tests = self._pre_process_tests(data['tests'])

Maybe _pre_process_tests should put failing tests in different buckets (timeout, crash, text).
Then, we would be able to update all 'Text' tests at once.
For logging, we could log all failing tests at once also, all crashing tests...

> Tools/Scripts/webkitpy/w3c/test_updater.py:218
> +        return p.wait()

I wonder whether we need to use Popen or whether could not directly run it directly since this is python.

> Tools/Scripts/webkitpy/w3c/test_updater.py:235
> +            'IMAGE': 'ImageOnlyFailure',

I wonder whether we have this kind of mapping already in our code base.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180607/b8fd9dad/attachment.html>


More information about the webkit-unassigned mailing list