[Webkit-unassigned] [Bug 165072] [GTK] Difficult to read combo box text in dark theme

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 1 04:58:19 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=165072

--- Comment #14 from Carlos Eduardo Ramalho <cadubentzen at gmail.com> ---
(In reply to Carlos Garcia Campos from comment #13)

Thanks for the review!

> Comment on attachment 341720 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=341720&action=review
> 
> > Source/WebCore/rendering/RenderTheme.cpp:219
> > +#if PLATFORM(GTK)
> > +    case ListboxPart:
> > +        return adjustListboxStyle(styleResolver, style, element);
> > +#endif
> 
> Do not use platform ifdefs here.

OK

> 
> > Source/WebCore/rendering/RenderTheme.cpp:952
> > +#if PLATFORM(GTK)
> > +void RenderTheme::adjustListboxStyle(StyleResolver&, RenderStyle&, const Element*) const
> > +{
> > +}
> > +#endif
> 
> We could have a default empty implementation in the header for ports not
> implementing this.

OK

> 
> > Source/WebCore/rendering/RenderTheme.h:310
> > +#if PLATFORM(GTK)
> > +    virtual void adjustListboxStyle(StyleResolver&, RenderStyle&, const Element*) const;
> > +#endif
> 
> Remove the platform ifdefs here and simply use an empty implementation here
> like other virtual methods do. I wouldn't make it const, even if it's true
> that the gtk implementation is const.

All the others adjustFooStyle() methods are const, so I just did the same. Those adjustFooStyle methods are supposed to operate on the RenderStyle reference passed as parameter anyway, and do not change any member data. I think it's better to leave it as const for consistency.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180601/f80a202b/attachment.html>


More information about the webkit-unassigned mailing list