[Webkit-unassigned] [Bug 188191] New: [WTF] Rename String::format to String::deprecatedFormat

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 31 01:10:47 PDT 2018


            Bug ID: 188191
           Summary: [WTF] Rename String::format to
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Web Template Framework
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: tpopela at redhat.com

>From bug 187955:

We should rename String::format to String::deprecatedFormat and start phasing it out. Clients can and should use string concatenation, clearly invokable as makeString or possibly just with the + operator, instead. More efficient, likely safer. A few clients might be using advanced features of printf, but even those could probably be added to the concatenation.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180731/dd6cf2ed/attachment.html>

More information about the webkit-unassigned mailing list