[Webkit-unassigned] [Bug 187728] Minor changes to the WHLSL interpreter to support the new compiler

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 20 12:02:20 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=187728

--- Comment #3 from Thomas Denney <tdenney at apple.com> ---
Comment on attachment 345161
  --> https://bugs.webkit.org/attachment.cgi?id=345161
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=345161&action=review

>> Tools/WebGPUShadingLanguageRI/FunctionLikeBlock.js:32
>> +        this._func = func;
> 
> Is this right? I thought the function would not have its generic types be instantiated, but the FunctionLikeBlock would.

FunctionLikeBlocks are only constructed with functions that have been instantiated.

>> Tools/WebGPUShadingLanguageRI/NativeFunc.js:41
>> +    set implementationData(newImplData) { this._implementationData = newImplData; }
> 
> Isn't there a better name for this?
> Also, I would sleep better at night if the constructor set it to undefined or null or something, just so it's easier to see all the members the class contains in a single place.

implementationData is used in a few other places in the interpreter for this kind of thing (e.g. struct accessors) so I'm aiming to be consistent with them.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180720/c155f25b/attachment.html>


More information about the webkit-unassigned mailing list