[Webkit-unassigned] [Bug 187311] MeasurementSet should merge last four segments into two if values are identical.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 3 19:31:15 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=187311

--- Comment #2 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 344252
  --> https://bugs.webkit.org/attachment.cgi?id=344252
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=344252&action=review

> Websites/perf.webkit.org/public/v3/models/measurement-set.js:245
> +            if (!segmentationSeries.length || value !== segmentationSeries[segmentationSeries.length - 1].value)

I think it's cleaner to move this logic to addSegment and rename it to addSegmentMergingIdenticalSegments.
The function can then just compare the last value of segmentationSeries and the newly computed value.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180704/dc8f64d5/attachment.html>


More information about the webkit-unassigned mailing list