[Webkit-unassigned] [Bug 180898] AX: AOM: Dispatch accessibleclick event

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 16 20:15:28 PST 2018


https://bugs.webkit.org/show_bug.cgi?id=180898

Ryosuke Niwa <rniwa at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #333841|review?                     |review-
              Flags|                            |

--- Comment #12 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 333841
  --> https://bugs.webkit.org/attachment.cgi?id=333841
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=333841&action=review

> Source/WebCore/ChangeLog:14
> +

Need a URL for the spec.

> Source/WebCore/accessibility/AccessibilityObject.cpp:2163
> +bool AccessibilityObject::dispatchAccessibilityEvent(Event& event)

I don't think we want to duplicate all this code here.
We should templatize the one in EventDispatcher.cpp and re-use it for regular DOM events and accessibility tree instead.
r- due to this code duplication.

> Source/WebCore/accessibility/AccessibilityObject.cpp:2166
> +    for (auto* parentObject = this; parentObject; parentObject = parentObject->parentObject()) {

Where this event path specified?
Are we sure we want to use the accessibility tree to dispatch events?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180217/739e43cd/attachment-0001.html>


More information about the webkit-unassigned mailing list