[Webkit-unassigned] [Bug 192622] [GTK][WPE] Fix forwarding webkit socket to flatpak sandbox

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 12 11:16:37 PST 2018


https://bugs.webkit.org/show_bug.cgi?id=192622

Michael Catanzaro <mcatanzaro at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mcatanzaro at igalia.com
 Attachment #357126|review?                     |review+
              Flags|                            |

--- Comment #7 from Michael Catanzaro <mcatanzaro at igalia.com> ---
Comment on attachment 357126
  --> https://bugs.webkit.org/attachment.cgi?id=357126
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=357126&action=review

Thanks for fixing Carlos's suggestions. LGTM, only one nit.

> Source/WebKit/UIProcess/Launcher/glib/FlatpakLauncher.h:39
> +GRefPtr<GSubprocess> flatpakSpawn(GSubprocessLauncher*, const WebKit::ProcessLauncher::LaunchOptions&, char** argv, int, GError**);

You should name the int parameter here. We use names in header files when the name would add meaning. E.g. we don't name the GSubprocessLauncher launcher or the LaunchOptions launchOptions, since that doesn't help readability. But the int should be named childProcessSocket, because that does improve readability.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20181212/c449d206/attachment.html>


More information about the webkit-unassigned mailing list