[Webkit-unassigned] [Bug 192561] New: Merge wtf/EventLoop and WebCore EventLoop, and rename it

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 10 11:22:24 PST 2018


            Bug ID: 192561
           Summary: Merge wtf/EventLoop and WebCore EventLoop, and rename
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Web Inspector
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: simon.fraser at apple.com
                CC: inspector-bugzilla-changes at group.apple.com

We have EventLoop in both JSC and WebCore. Almost everything seems to use the JSC one, but PageScriptDebugServer::runEventLoopWhilePausedInternal() uses WebCore::EventLoop.

The name “EventLoop” is in demand for HTML5 Event Loop stuff, so I’d like to free up this name if possible. I also think we should rename JSC::EventLoop to something more inspector-specific, since it isn’t a full EventLoop implementation. Can we even move its functionality into the RunLoop class?

Joe says:
> Sure we could easily rename these to be DebuggerRunLoop to free up the name.

> It could probably also move to the RunLoop class. There are some differences between the JSC one and the WebCore one which I believe are still important. But maybe one of the implementations can move down into WTF.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20181210/1e48aa7c/attachment.html>

More information about the webkit-unassigned mailing list