[Webkit-unassigned] [Bug 188996] Add IGNORE_WARNING_.* macros

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 28 06:26:10 PDT 2018


--- Comment #6 from Michael Catanzaro <mcatanzaro at igalia.com> ---
(In reply to Guillaume Emont from comment #5)
> I wish I could. But since they are used inside of macros, it looks like they
> need to be defined wherever the macro is used. I tried to alleviate this by
> using the _COMPILER_ prefix. I'm open to alternative ideas, but
> unfortunately, simply #undef'ing them is not an option.

Heh! OK then, no big deal.

> I hear your argument, and I think it makes sense. Though I think that indeed
> this kind of question is worth asking on webkit-dev at .
> To add to your proposition, if we were doing that, what about calling the
> macors "PRAGMA_IGNORE_WARNING.*" to make it clear that they are "like
> pragmas" and that's why we don't put semicolons afterwards?

Sounds good to me. Maybe webkit-dev@ will have alternate naming suggestions.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180828/bd90b1ec/attachment.html>

More information about the webkit-unassigned mailing list