[Webkit-unassigned] [Bug 186714] [Datalist][iOS] Add suggestions UI for TextFieldInputTypes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Aug 26 18:32:14 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=186714

--- Comment #10 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 348056
  --> https://bugs.webkit.org/attachment.cgi?id=348056
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=348056&action=review

> Source/WebCore/html/TextFieldInputType.cpp:879
> +    userActivated |= (type == DataListSuggestionActivationType::TextChanged);

Not sure I'd name this "userActivated", since we poke a hole in that constraint on iOS if type == DataListSuggestionActivationType::TextChanged. Maybe "shouldDisplaySuggestions"?

It also seems weird that we relax this constraint only for iOS. Is there a reason we need to gate this on user gesture more strictly for macOS, or can we remove this platform check?

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:396
> +    if (_contentView.get()

Nit - you don't need this null check because [_contentView assistedNodeInformation].hasSuggestions will evaluate to NO anyways if ! _contentView.

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:3233
> +    if ([textSuggestion isKindOfClass:[WKDataListTextSuggestion class]]) {

We chatted over IRC about several different ways to accomplish this. I think this is okay, but another way (that avoids a class check and possibly the need for a WKDataListTextSuggestion subclass altogether) is check if this text suggestion is one of the suggestions in -[WKDataListSuggestionsControl textSuggestions].

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180827/25c07efe/attachment.html>


More information about the webkit-unassigned mailing list