[Webkit-unassigned] [Bug 188877] New: TypedArray.set should be called with a string primitive values

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 22 20:52:42 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=188877

            Bug ID: 188877
           Summary: TypedArray.set should be called with a string
                    primitive values
           Product: WebKit
           Version: Safari 11
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: isol2 at cin.ufpe.br

version: 235121
OS: Ubuntu 16.04 x64

Steps to reproduce
let ta = new Int32Array(4);
ta.set("");

Actual results:
TypeError: First argument should be an object

Expected results:
pass without failures


V8, Chakra and SpiderMonkey works as expected.


cinfuzz

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180823/85518be2/attachment.html>


More information about the webkit-unassigned mailing list