[Webkit-unassigned] [Bug 188772] Allow override of viewport configuration

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 20 18:34:24 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=188772

--- Comment #3 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 347590
  --> https://bugs.webkit.org/attachment.cgi?id=347590
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=347590&action=review

> Source/WebCore/page/ViewportConfiguration.h:105
> +    WEBCORE_EXPORT static Parameters deviceWebpageParameters();

This is a somewhat confusing name. Maybe put it above webpageParameters() and add a comment saying that it uses device width and scale 1.

> Source/WebKit/WebProcess/WebPage/WebPage.cpp:1803
> +    if (m_page->settings().shouldIgnoreMetaViewport() || m_viewportConfiguration.setViewportArguments(viewportArguments))
>          viewportConfigurationChanged();

Why trigger viewportConfigurationChanged() every time if meta viewport is ignored?

> Source/WebKit/WebProcess/WebPage/WebPage.cpp:5320
> +    if (!m_page->settings().shouldIgnoreMetaViewport() && m_viewportConfiguration.setViewportArguments(coreFrame->document()->viewportArguments()))
>          viewportChanged = true;

Ditto.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180821/56e8f7a7/attachment.html>


More information about the webkit-unassigned mailing list