[Webkit-unassigned] [Bug 183621] Add support for the `inputmode` attribute

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 17 18:57:10 PDT 2018


Daniel Bates <dbates at webkit.org> changed:

           What    |Removed                     |Added
                 CC|                            |dbates at webkit.org

--- Comment #4 from Daniel Bates <dbates at webkit.org> ---
Comment on attachment 347413
  --> https://bugs.webkit.org/attachment.cgi?id=347413

View in context: https://bugs.webkit.org/attachment.cgi?id=347413&action=review

> Source/WebCore/html/InputModeNames.cpp:77
> +} // namespace WebCore::InputModeNames

// namespace InputModeNames

> Source/WebCore/html/InputModeNames.h:42
> +}


> Source/WebKit/Shared/AssistedNodeInformation.h:61
> +enum class InputMode {

We should specify a size fo this enum to get better packing. Otherwise, this enum will default to the width of int.

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:3554
> +        default:

I suggest we remove this "default" case and list any other enumerators. This will allow the compiler to ensure that this switch handles all enumerators.

> Source/WebKit/WebProcess/WebPage/ios/WebPageIOS.mm:2302
> +static InputMode inputModeForElement(const Node& node)

Can we come up with a better name for this?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180818/08005e1e/attachment-0001.html>

More information about the webkit-unassigned mailing list