[Webkit-unassigned] [Bug 176719] New: WKBundlePageWillSendSubmitEventCallback is called with incorrect frame parameter

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 11 12:08:01 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=176719

            Bug ID: 176719
           Summary: WKBundlePageWillSendSubmitEventCallback is called with
                    incorrect frame parameter
           Product: WebKit
           Version: Other
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebKit API
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mcatanzaro at igalia.com
                CC: bugs-noreply at webkitgtk.org, cdumez at apple.com
            Blocks: 173915

The definition for WKBundlePageWillSendSubmitEventCallback is this:

typedef void (*WKBundlePageWillSendSubmitEventCallback)(WKBundlePageRef page, WKBundleNodeHandleRef htmlFormElementHandle, WKBundleFrameRef frame, WKBundleFrameRef sourceFrame, WKDictionaryRef values, const void* clientInfo);

It's clearly intended to parallel WKBundlePageWillSubmitFormCallback, since almost all the parameters are the same. Now, in WKBundlePageWillSubmitFormCallback, the first WKBundleFrameRef, "frame", is the frame of the form target, and the second WKBundleFrameRef, sourceFrame, is the frame containing the form. That's correct. But in WKBundlePageWillSendSubmitEventCallback, both frame and sourceFrame are always identical. The problem is that the FrameLoaderClient delegate is called on the wrong FrameLoaderClient. It should be called on the FrameLoaderClient of the target frame, but HTMLFormElement calls it on the FrameLoaderClient of the source frame instead.

The forthcoming patch fixes this and adds a test. Since the change is in WebCore, it *technically* doesn't require owner approval, but it would certainly be good for someone from Apple to review it please.


Referenced Bugs:

https://bugs.webkit.org/show_bug.cgi?id=173915
[Bug 173915] [GTK] Add web process API to detect when form is submitted via JavaScript
-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170911/c1ff9610/attachment.html>


More information about the webkit-unassigned mailing list