[Webkit-unassigned] [Bug 178720] [GTK][WPE] Switch to use API::NavigationClient

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 29 23:54:42 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=178720

--- Comment #7 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to Alex Christensen from comment #6)
> Comment on attachment 324800 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=324800&action=review
> 
> > Source/WebKit/UIProcess/API/APINavigationAction.h:44
> > +    static Ref<NavigationAction> create(WebKit::NavigationActionData&& navigationActionData, API::FrameInfo* sourceFrame, std::optional<WTF::String> targetFrameName, WebCore::ResourceRequest&& request, bool shouldOpenAppLinks, RefPtr<UserInitiatedAction>&& userInitiatedAction)
> 
> I think we should just have one create function.

Why? targetFrame and targetFrameName are mutually exclusive.

> > Source/WebKit/UIProcess/API/APINavigationAction.h:85
> > +    std::optional<WTF::String> m_targetFrameName;
> 
> Could we have a null string meaning there's no frame name instead of an
> optional string?

Yes, sure, I guess we just need to decide which way is preferred in WebKit in general, because other reviewers have suggested the opposite in other patches.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20171030/bf314da3/attachment.html>


More information about the webkit-unassigned mailing list