[Webkit-unassigned] [Bug 178338] New: [JSC] We should have the op_in_by_id and op_in_by_val for "in" operations

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 16 05:59:12 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=178338

            Bug ID: 178338
           Summary: [JSC] We should have the op_in_by_id and op_in_by_val
                    for "in" operations
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: ticaiolima at gmail.com

Nowadays we just have "op_in" byte code that behaves much like "op_bet_by_val" bytecode. However the pattern ```"prop" in obj``` can be likely present in modern code, mainly on built-in functions like Object.prototype.defineProperty[1]. In Object.prototype.defineProperty case for instance, we could perform some more aggressive optimizations to enable Allocation Sinking and get speedups on relevant frameworks that uses this function (e.g Ember.js).

The idea here is to follow the same architecture used on "op_get_by_id" and be less conservative on DFG + FTL "op_in" compilation. One advantage that I have in mind right now is that we could compile IC as DFG nodes such as we perform on GetById.

[1] - https://bugs.webkit.org/show_bug.cgi?id=172888

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20171016/6cf95d91/attachment.html>


More information about the webkit-unassigned mailing list