[Webkit-unassigned] [Bug 179899] Allow for more efficient use of GenericTypedArrayView

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 23 09:28:56 PST 2017


--- Comment #13 from Darin Adler <darin at apple.com> ---
Comment on attachment 327378
  --> https://bugs.webkit.org/attachment.cgi?id=327378

View in context: https://bugs.webkit.org/attachment.cgi?id=327378&action=review

>>> Source/JavaScriptCore/runtime/ArrayBufferView.h:122
>>> +    inline bool getRangeImpl(char* destination, size_t dataByteLength, unsigned byteOffset, unsigned bufferByteLength);
>> The "inline" on all these functions are not needed.
>> Should these be void* instead of char*? Or maybe uint8_t*?
> Without them I get duplicate symbol errors at link time.

What I meant is that the inline should be on the function definitions, not here in the class. Not removing them entirely.

But maybe I am wrong about that. Maybe we should be moving toward doing it this way consistently instead, moving the "inline" keywords from the function definitions to the function declarations in the class above. There is at least one benefit to that, I think. The compiler can produce a warning or error if you call the function and it doesn’t have the function definition in the compilation unit, moving what would be a linker error to compile time.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20171123/516bc04b/attachment-0001.html>

More information about the webkit-unassigned mailing list