[Webkit-unassigned] [Bug 179837] New: AX: [ATK] Fix WKTR's methods for testing row header and column header presence and count

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 17 13:01:08 PST 2017


https://bugs.webkit.org/show_bug.cgi?id=179837

            Bug ID: 179837
           Summary: AX: [ATK] Fix WKTR's methods for testing row header
                    and column header presence and count
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: All
                OS: Linux
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Accessibility
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: jdiggs at igalia.com
                CC: webkit-bug-importer at group.apple.com

We currently have these methods:
1. rowHeaders() and columnHeaders()
2. getRowHeaders() and getColumnHeaders()

The methods in item 1 should return the headers if given a cell or a table. columnHeaders() does so, but rowHeaders() does not. These methods are to be implemented by all platforms, so we need to fix this.

The methods in item 1 should return an empty array and not nullptr upon failure. Tests might ask for the length of the array and we should handle that gracefully.

The methods in item 2 only get headers if given a table. Unlike the methods in item 1, these methods are just helper methods for our platform. Let's rename them to something a tad clearer.

The methods in item 2 call atk_table_get_{row,column}_header. Those ATK methods take an index and return a header if there's one there and otherwise null. We should not append null objects to the array of headers because it leads to bogus results.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20171117/0a181555/attachment.html>


More information about the webkit-unassigned mailing list