[Webkit-unassigned] [Bug 179125] New: Use more generic names than "overflow" for functions that can be used for subframes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 1 10:24:15 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=179125

            Bug ID: 179125
           Summary: Use more generic names than "overflow" for functions
                    that can be used for subframes
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Frames
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: fred.wang at free.fr
                CC: simon.fraser at apple.com
            Blocks: 149264

The following functions might need to be used by subframes to implement iframe scrolling on iOS (bug 149264). I'm not really sure about the best name to describe "overflow and subframes", but the name "overflow" might not be quite correct.

These are currently called when the current patch for bug 173833 is used:

PageClient::overflowScrollViewWillStartPanGesture()
PageClient::overflowScrollViewDidScroll()
PageClient::overflowScrollWillStartScroll()
PageClient::overflowScrollDidEndScroll()

I suspect we need to implement FrameView::didStartScroll, FrameView::didEndScroll (and  FrameView::didUpdateScroll) which would require the following functions too:


ChromeClient::didStartOverflowScroll()
ChromeClient::didEndOverflowScroll()

This ends up calling the following, but I'm not sure where they are used. I suspect they are meant to be overriden somewhere outside WebKit so I'm not sure we can just rename them:

UITextInteractionAssistant::willStartScrollingOverflow
UITextInteractionAssistant::willEndScrollingOverflow
UIWebSelectionAssistant::willStartScrollingOverflow
UIWebSelectionAssistant::willEndScrollingOverflow
WebUIKitDelegate::webkitViewDidStartOverflowScroll
WebUIKitDelegate::webkitViewDidEndOverflowScroll

I'm not yet sure about EditorClient::overflowScrollPositionChange (currently called from AsyncScrollingCoordinator::updateScrollPositionAterAsyncScroll).


Referenced Bugs:

https://bugs.webkit.org/show_bug.cgi?id=149264
[Bug 149264] IFrame scrolling=yes is ignored in iOS Safari
-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20171101/31057aa3/attachment-0001.html>


More information about the webkit-unassigned mailing list