[Webkit-unassigned] [Bug 173483] New: Port setup_environ_for_server should not set environment variables related with the driver.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 16 11:17:19 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=173483

            Bug ID: 173483
           Summary: Port setup_environ_for_server should not set
                    environment variables related with the driver.
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Tools / Tests
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: clopez at igalia.com
                CC: bugs-noreply at webkitgtk.org, lforschler at apple.com,
                    zan at falconsigh.net
            Blocks: 173433

On bug 173433 I found that the port setup_environ_for_server() is setting some environment variables (like DISPLAY) that should not be setted there.
Its the job of the driver (on _setup_environ_for_test()) setting that variables.


Referenced Bugs:

https://bugs.webkit.org/show_bug.cgi?id=173433
[Bug 173433] REGRESSION(r218344): [WPE] Thousands of layout test crashes
-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170616/72260aec/attachment.html>


More information about the webkit-unassigned mailing list