[Webkit-unassigned] [Bug 177993] Add UI for A/B testing on owned commits.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 21 14:13:42 PST 2017


https://bugs.webkit.org/show_bug.cgi?id=177993

--- Comment #16 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 330009
  --> https://bugs.webkit.org/attachment.cgi?id=330009
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=330009&action=review

>> Websites/perf.webkit.org/public/v3/components/combo-box.js:29
>> +    _constructTextField()
> 
> Rename this to _renderTextField.

Actually, do this in didConstructShadowTree instead.

> Websites/perf.webkit.org/public/v3/components/combo-box.js:33
> +            this._inputValue = textField.value;

We should access this.content('text-field').value instead.

> Websites/perf.webkit.org/public/v3/components/combo-box.js:109
> +        if (previouslySelectedCandidateElement)

We could just do: this.content('candidate-list').querySelector('.selected').classList.remove('selected');

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20171221/0126d379/attachment.html>


More information about the webkit-unassigned mailing list