[Webkit-unassigned] [Bug 175888] HTMLTrackElement behavior violates the standard
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Aug 23 10:35:41 PDT 2017
https://bugs.webkit.org/show_bug.cgi?id=175888
Eric Carlson <eric.carlson at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #318881|review? |review+
Flags| |
--- Comment #2 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 318881
--> https://bugs.webkit.org/attachment.cgi?id=318881
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=318881&action=review
r=me with a few minor suggestions.
Thank you!
> Source/WebCore/html/track/TextTrackCueList.cpp:109
> +void TextTrackCueList::removeAll()
Nit: I think "clear" would be a slightly better name than "removeAll"
> LayoutTests/media/track/text-track-src-change.html:33
> cues = testTrack.track.cues;
> + testExpected("cues === testTrack.track.cues", true);
This test can't fail. Did you mean to delete "cues = testTrack.track.cues;"?
> LayoutTests/media/track/text-track-src-change.html:51
> + errorEventTimer = setTimeout(loadedTrackTest(), 100);
This timeout is too short, it will fire before the error event on heavily loaded machines (e.g. on the bots). I would set it to a much larger value, say 10 seconds.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170823/25442b9c/attachment.html>
More information about the webkit-unassigned
mailing list