[Webkit-unassigned] [Bug 175279] [Tools] Add script to download a GitHub release

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 17 13:00:59 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=175279

--- Comment #8 from Alexey Proskuryakov <ap at webkit.org> ---
Comment on attachment 318091
  --> https://bugs.webkit.org/attachment.cgi?id=318091
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=318091&action=review

I'm not an expert either. My only comment is about usability - with a somewhat generic name, the tool should probably better explain what it does. It's too easy to assume that it gets the source code for the latest Gtk release or something like that. Maybe some example invocations would help.

Also, if it's actually downloading something, it should be called "download", not "get" I think.

> Tools/Scripts/get-latest-github-release.py:39
> +    parser.add_argument('--output', '-o', default='.', help='output directory')

It is a little annoying that curl's "-o" option has a different meaning, but I don't have a proposal for how to improve this.

> Tools/Scripts/get-latest-github-release.py:40
> +    parser.add_argument('--endpoint', '-e', default=PUBLIC_GITHUB_API_ENDPOINT, help='GitHub API endpoint (defaults to public)')

Do you envision a need to use a different endpoint? Will the users of the tool know how to make this choice?

> Tools/Scripts/get-latest-github-release.py:41
> +    parser.add_argument('--token', '-t', default=None, help='GitHub API OAuth token (where applicable)')

Again, will the users know if it's applicable?

> Tools/Scripts/get-latest-github-release.py:42
> +    parser.add_argument('--force', '-f', action='store_true', help='download latest release even if it already exists')

Exists where? Will this overwrite an existing file with the same name? Why is this option needed?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170817/c6d272a2/attachment-0001.html>


More information about the webkit-unassigned mailing list