[Webkit-unassigned] [Bug 175585] Support the 'with' keyword in FTL

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 15 16:19:29 PDT 2017


Saam Barati <sbarati at apple.com> changed:

           What    |Removed                     |Added
 Attachment #318192|review?, commit-queue?      |review+, commit-queue-
              Flags|                            |

--- Comment #2 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 318192
  --> https://bugs.webkit.org/attachment.cgi?id=318192

View in context: https://bugs.webkit.org/attachment.cgi?id=318192&action=review

> Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp:5655
> +            Node* scopeObject = get(VirtualRegister(currentInstruction[3].u.operand));

FWIW, I think a less confusing variable name would just be "object" instead of "scopeObject" here and in other places

> Source/JavaScriptCore/dfg/DFGFixupPhase.cpp:1713
> +        case PushWithScope:

I think it's nice to document like before as KnownCellUse instead of CellUse.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170815/8eafe2ee/attachment.html>

More information about the webkit-unassigned mailing list