[Webkit-unassigned] [Bug 175183] WebDriver: Implement page load strategy

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 4 11:12:52 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=175183

Brian Burg <bburg at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #317239|review?                     |review+
              Flags|                            |

--- Comment #2 from Brian Burg <bburg at apple.com> ---
Comment on attachment 317239
  --> https://bugs.webkit.org/attachment.cgi?id=317239
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=317239&action=review

r=me, great work. Please send through EWS before landing.

> Source/WebKit/ChangeLog:8
> +        Split pending navigation maps into normal and eager, and one or the other depending on the received page load strategy.

Nit: ... and *use* one or the other ...

You don't actually say why two maps are needed here.

> Source/WebKit/UIProcess/Automation/WebAutomationSession.cpp:459
> +static void finishPendingNavigationsWithTimeoutFailure(HashMap<uint64_t, RefPtr<Inspector::BackendDispatcher::CallbackBase>>& map)

Nit: I prefer a name like "respondToPendingNavigationCallbacksWithTimeout" or something.

> Source/WebKit/UIProcess/Automation/WebAutomationSession.cpp:519
> +    Inspector::Protocol::Automation::PageLoadStrategy pageLoadStrategy = defaultPageLoadStrategy;

Okay, we have this same code three times. Can you extract it?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170804/815aa3a1/attachment.html>


More information about the webkit-unassigned mailing list