[Webkit-unassigned] [Bug 174861] WebDriver: fix return value of close window command

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 3 17:06:51 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=174861

Brian Burg <bburg at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #316630|review?                     |review+
              Flags|                            |

--- Comment #7 from Brian Burg <bburg at apple.com> ---
Comment on attachment 316630
  --> https://bugs.webkit.org/attachment.cgi?id=316630
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=316630&action=review

r=me with naming change

> Source/WebDriver/ChangeLog:24
> +        (WebDriver::Session::closeWindow): Call closeTopLevelBrowsingContext() passing the current toplvel browsing context.

Nit: toplvel

> Source/WebDriver/Session.cpp:60
> +void Session::closeNextToplevelBrowsingContext(const String& toplevelBrowsingContext, Function<void (CommandResult&&)>&& completionHandler)

Shouldn't this entry point be closeAllToplevelBrowsingContexts? It closes more than just the next one.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170804/434cba2d/attachment.html>


More information about the webkit-unassigned mailing list