[Webkit-unassigned] [Bug 171268] Rename MockFileSystem.maybe_make_directory()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 25 08:57:30 PDT 2017


Carlos Alberto Lopez Perez <clopez at igalia.com> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|---                         |WONTFIX

--- Comment #2 from Carlos Alberto Lopez Perez <clopez at igalia.com> ---
(In reply to Michael Catanzaro from comment #1)
> Hm, this is not what I meant. I assumed it was obvious that
> maybe_make_directory() functions like "mkdir -p". So I think the current
> name is fine. 
> But we should have a function that operates like plain "mkdir"
> so that you can use it in tests in cases where the directory should
> definitely not already exist, as in bug #168036.

I don't think we need such function. If I want to ensure the directory doesn't exits I can test for that with MockFileSystem.isdir()

I'll land a follow-up patch for that in bug 168036.

> This is very unimportant. :)

Ok. Let's close this then.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170425/237bea04/attachment.html>

More information about the webkit-unassigned mailing list