[Webkit-unassigned] [Bug 171205] [GTK] Midori doesn't load home page, web inspector crashes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Apr 23 17:11:51 PDT 2017


--- Comment #2 from dirk.fizzlebeef at gmail.com ---
(In reply to Michael Catanzaro from comment #1)
> What version of WebKitGTK+?

Sorry about that. I'm using version 2.16.1 with the following features:

    [ Legend : U - final flag setting for installation]
    [        : I - package is installed with flag     ]
    [ Colors : set, unset                             ]
     * Found these USE flags for net-libs/webkit-gtk-2.16.1:
     U I
     - - coverage      : Enable code coverage support
     - - doc           : Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
     + + egl           : Enable EGL support
     - - geolocation   : Enable geolocation support through app-misc/geoclue
     - - gles2         : Enable GLESv2 support
     - - gnome-keyring : Enable support for storing passwords via gnome-keyring
     + + gstreamer     : Add support for media-libs/gstreamer (Streaming media)
     - - introspection : Add support for GObject based introspection
     + + jit           : Enable just-in-time compilation for improved performance. May prevent use of some PaX memory protection features in Gentoo Hardened.
     - - libnotify     : Enable desktop notification support
     - - nsplugin      : Build plugin for browsers supporting the Netscape plugin architecture (that is almost any modern browser)
     + + opengl        : Add support for OpenGL (3D graphics)
     - - spell         : Add dictionary support
     - - test          : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in make.conf/package.use
     - - wayland       : Enable dev-libs/wayland backend
     + + webgl         : Build support for the WebGL HTML API using virtual/opengl

> > When I go to midori-browser.org in Midori, I can see the page for an instant
> > before it goes blank. The following messages are produced in the console: 
> > 
> >     (WebKitWebProcess:27301): GLib-GObject-CRITICAL **: g_object_set:
> > assertion 'G_IS_OBJECT (object)' failed 
> This is the first problem, so let's worry about this one first. Could you
> get a backtrace to it please, using G_DEBUG=fatal-criticals?

I ran `G_DEBUG=fatal_criticals gdb midori` and hit that page, but I didn't see any additional information. I also tried setting `G_DEBUG=fatal-criticals` as well as setting it inside gdb using `set environment G_DEBUG=fatal_criticals` and `set environment G_DEBUG=fatal-criticals`. (I tried both because the glib docs say it is an underscore.) However, I only see a little additonal information:

    RenderNamedFlowThread 0x7fff90b7bc00 willBeDestroyed

    (WebKitWebProcess:18169): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed
    [New Thread 0x7fff7a12f700 (LWP 18334)]
    [Thread 0x7fff7892c700 (LWP 18174) exited]
    [Thread 0x7fff88be3700 (LWP 18043) exited]

> > Second, every time I attempt to open the web inspector on any page, it shows
> > an error page that begins with "Web Inspector encountered an internal error"
> Since this web inspector error is unrelated, please file a second bug for
> this.

Done: https://bugs.webkit.org/show_bug.cgi?id=171207

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170424/178f358a/attachment-0001.html>

More information about the webkit-unassigned mailing list